Herk

Mk4 2.2 TDCi hot diesel

Recommended Posts

Hi everyone, I have a 200 bhp Ford mondeo mk4 2.2 tdci from 2011, have had it for about 3 years and just replaced the fuel pump recently after I couldn’t start it anymore. Now there’s one error code left, P0168, and when it heats up properly (about 30 minutes after starting it from cold), it has no power similarly to a limp mode but there’s no engine check light on or anything. I am puzzled, have checked everything and also have made a small electronic piece which bypasses the sensor (by sending it a lower temp) and the car drivers perfectly but it reads 85-95C on the fuel pipes and around them.... anyone that has experienced this with a similar engine/model that could shed some light would be much appreciated.

Share this post


Link to post
Share on other sites

Hi, on the mk3, the temp sensor is on the back of the fuel pump.. I assume it's the same on the MK4. So, when you replaced the fuel pump you introduced a new temp sensor. If you've still got the old one, can you swap em over? 

Share this post


Link to post
Share on other sites

The fuel temp on my Mk4 2.2 is on top of the fuel filter ... 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.