Sign in to follow this  
Florin M

Ford Ka mk1 AC compressor not engaging

Recommended Posts

Hello,

I have Ford Ka from 2004 that I just purchased and I am trying to fix the AC system. 

I have checked the fuse and it was ok.

When i click the AC button with the fan on, I hear a relay clicking but I don't notice any extra load on the engine.

My guess is that there is something wrong related to the compressor clutch, and I am going to a garage tomorrow to get it checked out.

Any ideas what else could cause this?

Share this post


Link to post
Share on other sites

I went to the garage and it was completely out of gas. After a full refil it started blowing cool air.

Share this post


Link to post
Share on other sites

hope it stays working ok but there is a chance it will fail again, as, where did the previous gas go.

Share this post


Link to post
Share on other sites

Yeah, that is a posibility, but since I don't know when was the last time it was recharged, I will have to chance it and hope it will blast cold for this summer at least.

Share this post


Link to post
Share on other sites

I has same problem on 2001 ka, no gas in system, turned out to be a/c hose was rubbing against the exhaust and split the rubber hose.

Share this post


Link to post
Share on other sites

Will keep that in mind, I have had the car for a couple of days and the AC still blows cold 🙂

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this