Jump to content
Do Not Sell My Personal Information


Recommended Posts

Hey Guys,

I'm having issues with the DAB on my Edge. I have a topic open in the audio forum on this.  Is there anyone out there in Edge crew that is willing to pop the rear cover in the tail gate and take a photo of their two DAB modules for me please? I need to compare against mine as the new part number Ford have given me is for the complete apim module rather than the antenna isolators.

New ford part No: 2374661

Thanks.

Link to post
Share on other sites

Please can anyone help me. I need a picture of the Ariel amplifier isolators behind the tailgate cover. This is mine below and we believe the red module is the wrong one. Need a close up of the all the info on its covers please.

IMG_2144.JPG

IMG_2145.JPG

Link to post
Share on other sites

Oh yes. Thank you very much Trent Edge. I have used your info with mine with Vospers Ford and have now found the correct module. 2371298 which is priced at £14.57 inc vat. 

 

So thanks Trent Edge and Andrew at Vospers 🙂 I have now ordered and looking forward to getting my radio back 

Link to post
Share on other sites
  • 2 weeks later...

So here are the parts we ordered to fix the DAB issue and a little extra to enable the ACC. Update to follow later. I seriously hope the DAB works after this!

IMG_2318.JPG

IMG_2320.JPG

IMG_2321.JPG

IMG_2322.JPG

Link to post
Share on other sites

Hi all,

 

I am VERY pleased to say that we now have DAB working. Andrew at Vospers was right when he said the RED antenna isolator was the wrong part. How very interesting considering this is how I bought the car. Our Edge was a PCP return, so unless it had a problem before and someone tried changing it, it was fitted with the wrong module.

Never mind, I'm slightly over £70 lighter for the two isolators that were needed, but I have working DAB.

IMG_2381.JPG

IMG_2321.JPG

IMG_2384.JPG

IMG_2144.JPG

Link to post
Share on other sites

Not as half as I am. I can't believe that someone has played with it under their PCP contract or Ford fitted the wrong module. No way did Ford fit the wrong module, so someone has played about with it before we had it. I'm just glad I've got it working for such a low cost, but has taken 5 months and a lot of phone calls and emails and tests to resolve.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Forums


News


Membership