Jump to content
Do Not Sell My Personal Information

2013 cmax no power steering


KerryK
聽Share

Recommended Posts

Hi. I'm so stressed. My 62 plate cmax has decided to give up on me. This is the second time it's happened after a 2.5 hour journey. Last time it happened I got out of the car for about 15 minutes. Got back in and it started beeping at me. No power steering on the dash. I had no choice other than to drive it home. It took 3.5 hours. I took it to the auto electrician and they couldn't find a fault. I went to pick it up and it worked when I started it. This was 4 months ago. Never happened again until today. Again around a 2 and a half hour journey. Was out of the car for 20 mins, got in and the same beeping and no power steering on the dash. Has anyone else had thus problem and what did you do? I've plugged it into the code reader again and there's no fault showing up. Any advice would be appreciated 馃槉

Link to comment
Share on other sites


So I've been looking on here and tried looking for water ingress but there seems to be none anywhere. Disconnected a few wires and reconnected but still has the power steering loss. Still no fault showing up when I scan it.

Link to comment
Share on other sites

Latest Deals

Ford UK Shop for genuine Ford parts & accessories

Disclaimer: As the club is an eBay Partner, The club may be compensated if you make a purchase via the club

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

聽 Pasted as rich text. 聽聽Paste as plain text instead

聽 Only 75 emoji are allowed.

聽 Your link has been automatically embedded. 聽聽Display as a link instead

聽 Your previous content has been restored. 聽聽Clear editor

聽 You cannot paste images directly. Upload or insert images from URL.

聽Share






  • Create New...

Forums


News


Membership