Jump to content
Do Not Sell My Personal Information


Introduction of a newbie


srwlml23
 Share

Recommended Posts

Afternoon I have just purchased an S-max 2.2 on a 2011 reg, It's got all the bells and whistles and looks a real decent motor, I am not usually a forum browser due to my age a tech  knowhow but I can think of no better place to get the advice... The sat nav is the issue, it struggles find my location it can take hours if at all! I have tried to calibrate it but it just stayed at 0% so I factory reset and it then showed 1% but nothing more

I understand there is a cd compartment below the radio and this may need to be replaced? although when I check these are only upto the date 08/2010 year

On startup the system say FordConvers+ and appears to be the same system in the stock photo ..Any and all advice greatly received

la.jpg

  • Like 1
Link to comment
Share on other sites


Have a read of this thread (link below). Your radio/satnav is at the change over age so it could be DVD or it could be SD card. Watch the video in the link that shows how to take the bottom panel off the radio. Behind the cover will either be a DVD slot or a SD card.

If your system is struggling to find satellites then there is a good chance it is a problem with the Satnav aerial.

 

 

Link to comment
Share on other sites

5 hours ago, srwlml23 said:

Afternoon I have just purchased an S-max 2.2 on a 2011 reg, It's got all the bells and whistles and looks a real decent motor, I am not usually a forum browser due to my age a tech  knowhow but I can think of no better place to get the advice... The sat nav is the issue, it struggles find my location it can take hours if at all! I have tried to calibrate it but it just stayed at 0% so I factory reset and it then showed 1% but nothing more

I understand there is a cd compartment below the radio and this may need to be replaced? although when I check these are only upto the date 08/2010 year

On startup the system say FordConvers+ and appears to be the same system in the stock photo ..Any and all advice greatly received

la.jpg

Hi welcome

Link to comment
Share on other sites

Morning and thank you for the welcome .. I have just checked and it is an SD card and if it is the latter and it is the aerial can these still be replaced these days are they all coded to their own system?

 

Link to comment
Share on other sites


Brilliant thanks for the heads up unofix

 

Link to comment
Share on other sites

That link is from S-Max from 05/2015 to 03/2016 I'm sure I'll find the correct one with some research.

Link to comment
Share on other sites

You need a card for the MCA unit, same as mine. This is what I have although I got it via eBay for about £22 (can't find one on there currently).

I don't think it will fix the issue but worth a try. 

There was a firmware update in 2015, have a read here https://mk4-wiki.denkdose.de/artikel/nav_mca/firmware_update_sp2015

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




×
×
  • Create New...

Forums


News


Membership