Sign in to follow this  
goulders

Warning Lights/instrument Cluster Fault

Recommended Posts

I have searched through the forum before posting, but cant find an answer that fits this particular problem and was hoping someone could help. The car is a 2005 Fiesta Mk6 1.5Tdci. Basically, the following warning lights on the instrument cluster keep coming on at RANDOM intervals:- ABS light, Engine management light, handbrake light, Immobiliser light, temp light and diesel coil light. They all turn on and off at the same time. Also, the rev counter and speedo stop working intermittently and the engine temp graph goes up and down and the trip for the mileage displays a line instead of the numbers. I have also a few problems starting the engine. I am aware of the issues with ABS module, but all those faults report that just the ABS, engine management and Handbrake lights coming on. I seem to be getting more lights and other symptoms. I also know the Focus had similar issues with the instrument cluster, but I cant find any reference to the Fiesta having the same issues. Can anyone shed any light on the cause of the problems? Cheers.

Share this post


Link to post
Share on other sites

I have cleared all the fault codes and all is working again. Hopefully, that will be the end of it, but knowing my luck, it wont be!!

Share this post


Link to post
Share on other sites

I would suspect a loose power connection to the instrument panel or a bad instrument panel. Something cheap to check - be sure the fuses are all pushed in all the way.

Share this post


Link to post
Share on other sites

I am having the same problem on my Focus LX 06 model. It happend to me in February then randomly just stopped. Two days ago I put my key in turn it then suddenly the red light in the middle (i will post video) starts flashing, my display shows --------- instead of my miles, as well as when I try to turn on my engine... simply nothing happens.

I want to get this fixed before my cover runs out at 100,000 miles and wont be fixed by the people i got the car from. When they plug the device to check for faults it doesnt come up with any faults. All i got is the video to prove it.

Any ideas?

VIDEO http://www.youtube.com/watch?v=iWE6JpekP2U&feature=youtu.be

Share this post


Link to post
Share on other sites

Ok will check that tomorrow. thanks :) will let you know how I got on

Share this post


Link to post
Share on other sites

Red flashing light is related to PATS failure or immobilisation. Looking at the symptoms of the focus you require a new cluster. The PATS system is integral to the cluster. Pretty confident on that one. Be advised. Cluster has to be programmed and keys coded again.

Share this post


Link to post
Share on other sites

hi guys.... sorry i was away for a long time. Right here is my story so far:

My car was taken with a finance company. I missed my payment this month, now the car has been immobilized, now when I turn the key the dash looks normal. So I am thinking if this could be down to the device that they have installed or the actual immobilizer being faulty.... but normally I would just have to press on the dash (where it shows my revs) then the dash returns to normal, but obviously happens again.... Finance company are refusing to take the car back, I have been reporting this problem since February since I got it from them..... any ideas on how i can return it to then and get the contract canceled without paying it off or maybe will be easier to fix it?

Share this post


Link to post
Share on other sites

Hi Luke,

First of all get your finance company to provide in writing the reason that they are failing to honour the contract. If the reason is due to missed payments, then the contract may be void, in which case they have the right to take the vehicle back without cooperation. However, if the contract is deemed active by you still making payments, then they must honour the contract and support you with the faults on your vehicle.

If the car was bought from a dealership (surely it was) then the dealers have a minimum 6 months obligation to support the vehicle (see my signature) in which case the onus of responsibility is to the dealers / garage.

When you paid the deposit for the car, did you pay anything at all on a credit card?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this