Jump to content
Do Not Sell My Personal Information


Engine Management Light


nikki-p
 Share

Recommended Posts

Hi there,

Can anyone help with a problem?

I bought my Daughter an 03 streetka 7 days ago, drove it 62 miles with no problems, stopped for an hour, drove 3 miles and it didn't feel right!

The engine management was flashing and the car was losing power on small hills, and it sounded more like a V.W camper!

Called out the A.A, no help at all, they suggested change the fan belt.

Took it to a mechanic who put it on a diagnostic machine and it came up with a misfire on 3.......changed the injector, put on new belt, plugs, leads, coil, etc

It was running great for an hour then low and behold exactly the same problem has happened.... engine management light has started flashing again and it sounds lumpy as before, any ideas what we can do next....... cos I'm wishing now that i hadn't bought it :-( especially as it was meant for my daughter's 18th

Thanks

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Forums


News


Membership