Jump to content
Do Not Sell My Personal Information


Problem With Ford Ka.


kat89h
 Share

Recommended Posts

hi

i was just wondering if any1 can help me , i have a 2006 ford ka . my abs light came on last wed , then the speedo has stopped working , after driving home carefully i switched off the engine , switched it back on to be greeted by the engine warning light also!

ive heard this could just be the speed sensor? is there any other problems this could be?

Thanks

Link to comment
Share on other sites

Thank you , :) . my brakes have been sqeeking for a while to when they are applied dont know if this could be linked , they work fine though , just dont want to be ripped off by the garage ! when it could be someting quite small .

Link to comment
Share on other sites


not much just to work and back which is only like 3/4 miles a 10 min trip , only had it since october and dont even think ive done 1000 miles yet , my dad says the sqeeking could just be dust on the brakes but its been a few weeks now.

Link to comment
Share on other sites

Always important to get your bakes checked out , the squealing may be due to the wear plug , meaning your pads may need changing.

Link to comment
Share on other sites

Mine go like that particularly through the cold wet weather and its just because I dont use them much ive had new discs and pads fitted and its stopped the problem altogether now though. You might find you're discs are a bit rusty cause theyve not been used much. Like Pree said get them checked while its in

Link to comment
Share on other sites

thanks , i will mention it , ive herd the speed sensor going on kas can be quite common ? now to find a reasonable garage that dont over charge me coz im a young lass!! haha.

Link to comment
Share on other sites

UPDATE! right took it to the garage this morning , and he ran the usual test on , but apparently the car was not speaking to the computer , and the hole abs system might need doing which would be around 500£ maybes get a second hand one .but said it would need proper diagnostics tests to get down to the real problem, he had to take it to his friends garage as his laptop is away for repair and has sent me there, he said it was a common problem on the fiesta but not so much the ka , does this sound right

i feel like crying :(

Link to comment
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Forums


News


Membership