Jump to content
Do Not Sell My Personal Information


Focus Mk2 Rear Loudspeakers Issue


Jurik
 Share

Recommended Posts

Hi folks,

I have my mk2 Focus 2006 1,6 Ghia and rear loudspeakers don't work at all. I have checked connectors and are plugged and ok. I have removed radio and big connector from the back looks fine as well. Since both repro don't work I don't think it would be problem of wiring or contact issue... What do you think? I have no voltmeter or something like that so I apriciate some help. Thanks

Link to comment
Share on other sites


I actually had both back Speakers on my mk2 go at the same time mid way through a song that was not being played loud at all..., it was really weird. BOTH went, I know because I turned the fade onto the back and there was no sound at all! I haven't had time to dig into whats going on, however I DID notice that the rear driver one was making some noise again the other day, but the rear left is still silent.

Best of luck with your issue..

Link to comment
Share on other sites

Hi Troy,

It was one of the first things I have checked. The "Fade" option I don't have in menu. There is only "Balance". Btw I have cd6000 sound system. I bought my car in January his year and Speakers didn't work but I didn't know they should even it was strange for me :) so I would like to fix it somehow...

Thanks

Link to comment
Share on other sites

No problem if that's the first thing you checked, sometimes asking the easy questions first spots something that was missed.

If you've been able to get the trim off to check the speaker connections, as a next step you could get hold of a known working speaker and try wiring that in. Will help narrow down if you're looking at faulty Speakers or headunit/wiring problem.

Link to comment
Share on other sites

You know that these radios have two amps? one for front and one for the rear. Most of them are done with push-pull mosfets and they just die without warning. Get a loan of a meter and set it to resistance and measure across the speaker terminals. You should get a highish reading. Id put my money on the stereo itself. My CD 6000 blew its front right channel. i just bought a pioneer single din to replace it with. waiting for the facia adapter to come now

Link to comment
Share on other sites

:) I did my best and friends on forum did good job with manuals how to remove the door trim panel. That's good idea Troy... But Speakers are riveted and I have no extra speaker yet. But this sounds for me as the easiest way how to work out what's going on. Thanks a lot

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Forums


News


Membership