Jump to content
Do Not Sell My Personal Information


Ford Ka Edge Aux Input Problems??


farmerlisa
 Share

Recommended Posts

Hello all!!

I bought a Ford KA Edge 2010 last month, and slowly getting used to it. But one thing that's nagging me is that the Aux Input socket seems broken. When I try and put in an aux cable, it doesn't fit and is very loose. Do I have to purchase a cable from Ford directly for this or is it possible I have a dodgy cable... OR is it a problem with the socket... The other end of the Aux Cable fits fine in my phone...

I'm well and truly baffled. Please help!

Many thanks

Link to comment
Share on other sites


Standard aux in socket on car, so if it dont fit right , then socket faulty, have you tried another cable to make sure its socket at fault?

Link to comment
Share on other sites

Thanks for replying. I haven't tried another aux cable, no, as I don't have one. Didn't think it would be worth getting one if it's the socket faulty.

However!... I called my local Ford today as I needed to call them anyway for another reason (I won't go into that...), and the guy from parts said how a lot of people have the same problem, a majority being those who own Ford Fiesta's. Ford sell their own aux cable that apparently works - so when I'm next in he said he'll keep one by for me. Still find it all very odd though...

Anyone else had the same problem?

Sent from my iPhone using Ford OC

Link to comment
Share on other sites

  • 7 years later...
On 1/8/2015 at 11:00 PM, farmerlisa said:

Hello all!!

I bought a Ford KA Edge 2010 last month, and slowly getting used to it. But one thing that's nagging me is that the Aux Input socket seems broken. When I try and put in an aux cable, it doesn't fit and is very loose. Do I have to purchase a cable from Ford directly for this or is it possible I have a dodgy cable... OR is it a problem with the socket... The other end of the Aux Cable fits fine in my phone...

I'm well and truly baffled. Please help!

Many thanks

hi i’m having this same problem now, were you ever able to fix it and how did you do it?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




×
×
  • Create New...

Forums


News


Membership