Sign in to follow this  
RichHorrocks

Focus Mark 2: Electrical Engine Management Problems

Recommended Posts

Apologies in advance for length...


I recently repaired some crash damage to the front of my Mark 2 Focus. The repair involved a new bumper, passenger-side wing, ECU housing, all the bits of plastic in that area, tie-rod, other wheel bits, etc. Basically the front and front nearside of the car.


The car was sitting for about 2 years, during some of which it was exposed to the elements, some of which it was garaged. When outside, the ECU was hanging free, but protected by a plastic bag. (There wasn't really anything in that area of the car to protect it. The car was also covered by a tarp.)


I recently (finally) finished the repairs, and the car passed its MOT first time, with the only note (advisory?) being that parts of the underside showed corrosion. That was a couple of weeks ago.


I'm now having what I assume to be electrical problems, which started a few days ago.



1) Main problem


The following lights show all the time on the dash:

  • red battery warning light
  • yellow engine management light
The central LCD says ENGINE SYSTEMS FAULT. (With the red LED next to it being lit.)

The car starts and runs fine.


I've read the faults with a reader and found the following:

  • U0140 - lost communication with body control module
  • U0422 - invalid data received from instrument panel or body control

2) Intermittent problem #1


The Main Problem remains, but with the addition of:

  • STEERING ASSIST FAILURE on the LCD screen. (With the yellow LED next to it.)
  • The handbrake warning light starts to flash.
The car continues to drive, and it doesn't seem that the power to the steering changes.



3) Intermittent problem #2


The yellow ABS warning light comes on while driving, and the speedo stops working (it just drops to zero mph). The tacho dial remains working fine.


The car still drives fine.



4) Intermittent problem #3


This happened today.

The whole instrument panel switched off while driving. The car remained running and moving, but I lost power steering completely during a turn. (Meaning I'm not using the car again until all this is resolved.) The turnover also became lumpy, but the car didn't stop or appear to slow down. (i.e. It didn't go into Limp Mode.)


Problems 2), 3) and 4) give me the following error codes (I haven't decoded them):

  • P03c1
  • C00e1
  • B17c4
  • P2200


So a right bag of problems.


Where should I start? Has the ECU rotted away from the inside while the car was sitting out in the elements, or could it be something less drastic than that? Should I investigate the Main Problem first and hope that the intermittent problems will disappear once the Main Problem is fixed?

Share this post


Link to post
Share on other sites

When I bought our mk2 1.8 tdci (56) as a project, it had multiple fault codes, and eventually came up with a no comms code.

The previous owner had been told he needed a new dash binnacle and was quoted around £1500 to repair.

I removed the binnacle and ecu then sent them off along with the keys to BBA Reman for testing, which cost £35 pounds

They were returned as working correctly

A thorough check of the electrics found corrosion under one of the multiplugs in the fuse box under the passenger dash.

013_zpsaffe61b6.jpg

I decided to replace the fuse box as it has integral control modules.

You need to get the exact part numbers but it is possible to get one from a breakers

It was neccessary to have the new modules coded to the car.

With the car now up and running I split open the old fuse box to view the horrors within.

It looked ok from the top but the underside was badly damaged

020_zps3a0f119a.jpg

015_zpsdd65c775.jpg

016_zps141f6606.jpg

It's possible that the damage to yourcar has allowed water to get in, apparently it can trickle down the loom and enter the fuse box.

worth checking

BBA Reman gave me good service if you want some where to check the ecu and binnacle.

They will quote for repairs or replacement if your parts are faulty or just charge for testing if they're not.

good luck and let us know how you get on.

Share this post


Link to post
Share on other sites

The U codes don't necessarily mean anything, these can be caused by the diagnostics process.

The other codes look very random and not the codes I would expect so decoding them might be quite a feat.

You really need to get the car on either IDS or Forscan to find out what codes are present and to investigate them further.

I have both however you are a fair way from me depending on where you are in Leicestershire if you want to PM me and let me know where you are I may be able to come and assist you on looking into your issues further.

Although I would suspect with the issues you are having it is possible it is a faulty instrument cluster and needs replacing, these can be replaced but will need coding to the car and the keys recoding with IDS. Ideally you would need an HEC off an identical car with the same options as yours and engine type with lower mileage than your car is showing as the mileage can the be written up to the correct figure on your car, you can't write the mileage down only up with IDS for installing a new HEC.

But first before anything you need the codes read and checked out properly on some decent diagnostics that can help you see where the problem lies.

P2200 is just a generic code for Nox sensor circuit which tells you nothing really.

The other codes are also very vague as they seem to be some generic codes that might not mean what they appear to mean when if you Google them.

Share this post


Link to post
Share on other sites
I've finally managed to spend some time looking at this today - apologies for the late response.


Thanks for the very detailed set of pictures, Colin. (And the pointer to BBA Reman - that might come in useful... )


I've had the passenger-side internal fuse box out this morning. It's bone dry and looks like the day it rolled out of the factory. So corrosion-wise it's okay. The clusters of wires coming into the fuse box also look dry, so no trickling down from the engine bay/scuttle area. (I know that doesn't rule it out completely.)


What is a dash binnacle? Is it the same as the "instrument cluster"? (Which from what I can tell is all the electronics behind the dials/dash.) I'm planning to also take this out today and have a look for water ingress, etc. (I've found a YouTube video that tells me how to do this... )


Colin - I took your advice and didn't bother decoding the random error codes :)


What does an IDS or Forscan give me over the cheapo bluetooth thing I've used (Torque and an OBDII plug-in thingy)? Is it possible to just download the software and use my phone/iPad, or is there some special hardware involved? (IDS appears to be a special bit of gear, but is Forscan just a program I can download?)


Is a faulty instrument cluster always obvious from a visual inspection? (Like water damage, lose connections, bad soldering, etc.) Or can it be something that isn't so obvious, and there's basically nothing you can do other than replace it?


Thanks for the help so far guys.

Share this post


Link to post
Share on other sites

You could try Forscan with your bluetooth OBD and see if it works if it available on the apple store but wil cost a couple of quid, but it will give you full manufacturer specific codes rather than the odd generic type codes your current diagnostics has given you.

Forscan and or IDS can talk to almost everything on the car and that can help with figuring out what is wrong, Forscan does not do as much as IDS does so may or may not help in this case.

If it was me I would do a full cluster test to confirm everything is working there first, then I would look at the DTC codes that are present, clear them and then drive the car again and see what error codes come back. Also checking if IDS can communicate with everything on the car it should be able to communicate with, anything suspect it can't communicate with would suggest a possible ECU or wiring fault or a faulty cluster.

I would also be looking at the firmware of the HEC and settings to see if there are any issues there including voltage of them but that is where IDS or elmconfig comes in, save the files and try writing them back to the cluster, if the cluster was faulty I would expect difficulty either reading it or writing to it.

Then as a last resort if I still wasn't sure if it was the HEC then I would try and get one from a scrap yard from a 1.8 and try that in place and code it all up and see if the problem is resolved, ideally one with a lower mileage than your car so the correct mileage can be written to it, only up not down.

That's sort of what I would be trying to ascertain the fault, basically a process of checking and elimination.

Share this post


Link to post
Share on other sites

Ford IDS gives you the error codes that are present and also gives information on what could be causing those error codes and things to look at, obviously being a main dealer tool it does more than Forscan does although Forscan is very good.

Share this post


Link to post
Share on other sites

The other thing I would be checking is the C90 connector in the engine bay fuse box if you have removed it at all whilst doing your repairs.

Share this post


Link to post
Share on other sites

Forscan won't communicate with all the ECU's without a modified OBD adapter either so may not give you all the error codes that are present a some ECU's communicate on the High speed can network and some communicate on the Medium speed can network.

This is why I have an IDS clone which does most things, a modified ELM 327 cable along with Forscan and Elmconfig as I can cover pretty much any eventuality.

Share this post


Link to post
Share on other sites

You can remove the back plate of the instrument cluster to check for water ingress or bad soldering or burn marks.

Share this post


Link to post
Share on other sites
Okay, I've got Forscan up and running. Thanks for the pointer to it.


Currently the car is only exhibiting the Main Problem that I originally outlined, though with slightly different symptoms. The red battery light is on, but the yellow engine management light isn't. The battery is brand new, and I'd already checked the alternator, which is giving ~13.7 V.


I've cleared the existing code and started the engine (I'm starting again now that I have Forscan). Forscan seems to be able to communicate with all the modules, looking at its logs.

The two codes I get are as follows:


Powertrain Control Module: B1473-68 - Generator Field Terminal Circuit


Suggestions from Forscan are:

* Short to power

* Blocked vacuum hoses

* Faulty or damaged PCM



Instrument Cluster Module: U1900-20 - CAM Communication Bus Fault - Receive Error


No suggestions on this one, other than that U codes might just be an indicator of inter-module communication problems. (Which had already been suggested.)



Presumably the first of these is the most important. Google isn't helping with providing any other examples of how to go about looking at it. The only other mention to this Ford error is related to the wiper motors... (And this error seems to be shared with Mazda and Vauxhall, though with different decodes.)



I'll have a look at the C90 connector this afternoon, but I don't think I touched it in my repairs. (I had to look up what it was.)

I'll also get clued up on HEC stuff (I currently don't know what it is).


Thanks so far!

Share this post


Link to post
Share on other sites

After removing the cluster lift the tabs all the way around with a flat blade screwdriver to remove the back cover.

t0j2jb.jpg

Then have a good look at the PCB

15s282f.jpg

That is a HEC from a 1.6 petrol I managed to pick up from a scrapyard to play with, not that its really any use to me.

Share this post


Link to post
Share on other sites

Okay, the plot thickens.

I've removed the instrument cluster (which is the same as the HEC, right?). I'm presented with the below, which would indicate that there've been problems before. I don't have the immediate details of the family I bought the car from (it was 5 years ago now), and there's nothing in the service history or paperwork.

The outside casing has a note taped to it(!). The label on the right also appears to be water-damaged (though I suppose this *could* just be normal ageing). The hole for the plug has the end pin numbers pencilled on.

post-55043-0-48624900-1440776143_thumb.j

Inside the casing is this:

post-55043-0-11103100-1440776081_thumb.j


Is this an after-market board? It has "DS" etched into the surface, and the dials are Sonceboz. I'm assuming I should be staring at the underside of a PCB, but in the case of this board everything is on the inside, which makes it difficult to access. Can I remove the PCB to look at the other side, or is it held in place by the arms of the dials? (I had a quick go at unclipping it, but it didn't want to come off.)

The hole in the dash looks dry, and the wiring all looks un-water-damaged. However, two of the wires seem to have been spliced/repaired at some point as they have black tape around them. The two wires are green-blue and green-yellow:

post-55043-0-86636300-1440776241_thumb.j

I haven't worked out what these equate to yet.

I cleaned the plug/socket with switch cleaner and reconnected it. I cleared the error codes, and started the engine, but the two errors came back (and the battery light is on). I haven't properly reattached the HEC, so I can poke around further as required.

I'll get onto the C90 next.

Share this post


Link to post
Share on other sites

Well it's not what I was expecting to see. To remove the board the needles do need removing but getting then back I'm the correct place is not that easy. The one I had apart was showing 80mph at a standstill. Lol they are stepper motors and if you put the needles back at rest positions they should be OK but I would not recommend it.

It has obviously had cluster problems at some point. Hec means hybrid electric cluster so yes instrument pack.

Share this post


Link to post
Share on other sites

Didn't get around to looking at the C90 properly, though have decoded the colours of the two spliced wires from behind the HEC (using the PDFs from the sticky wiring diagram thread):

  • Green/yellow - Ignition
  • Green/blue - Accessory (crank) [whatever that is... ]

I'm going to assume that these aren't currently a problem, but that they do indicate an issue in the past which was presumably fixed.

Share this post


Link to post
Share on other sites

Personally I would look at the battery charging system first.

A voltage of 13.7 Volts is very low if the engine is running. The Focus MK2 requires a Silver/Calcium or Calcium/Calcium battery. The charging voltage required to charge this type of battery is between 14.4 and 14.8 Volts. The low battery voltage can also cause several communication errors.

A simple check is to remove the small 3-pin connector from the alternator. if the connector is removed the Smart Charge alternator will work as an ordinary alternator. If the alternator is functioning correctly the voltage should be between 14.4 and 14.8 Volts.

Share this post


Link to post
Share on other sites
Thanks for the tips :)


The battery is only a few weeks old. It's an Exide Premium EA722 (from Europarts), which I've checked is calcium. (I didn't check before I bought it...)


I've taken the voltage again, and it's showing around 14.5 V. (I'm not sure how I managed to get 13.7 V the last time.)


I've then removed the 3-pin connector and taken a voltage. In this case I only get around 13.8 V (close to the 13.7 V I mentioned before... ). Should this be higher? Does this low voltage mean the alternator is playing up?


Perhaps the fact that the voltage without the 3-pin connector is close to what I measured before (with the 3-pin connector) might suggest there's a lose connection or break?


EDIT:


This thread suggests that 13.8 V is okay for the case where the connector isn't connected. I'll investigate the possible breakage idea if I can get my electrical skills up to scratch :)

Share this post


Link to post
Share on other sites

One further thing.

I've noticed the wires from my alternator's 3-pin connector are coloured blue/green, red/grey, red/grey (i.e. two wires the same colour!). All other references to these wires that I can find say that they should be grey, red, blue. This might indicate that these have been changed in the past, unless someone can confirm that they also have similar coloured wires.

Share this post


Link to post
Share on other sites

I've removed the shielding from the wires coming off the alternator's 3-pin plug, and the plug seems to be new. The old blue/red/grey wires are joined about 6 inches downstream. The connections are soldered and heatwrapped, so I'm not too worried.

The smart charge seems to be working from the voltages I took. (See a couple of posts back.)

However, I can't get any continuity between pin 3 (the red one) and either side of fuse 31 in the main fuse box, nor the battery.

Also, there seems to be a connection between pin 1 (the grey one) and the battery. The grey wire should be going direct to the ECU.

Surely these would indicate a break somewhere, but if that's the case, how would the smart charge be working?

Share this post


Link to post
Share on other sites
I've solved what I'd initially reported as the Main Problem.


This was initially reported as the error code U0422, but once I started to use ForScan, the error seemed actually to be:


Powertrain Control Module: B1473-68 - Generator Field Terminal Circuit


The problem was related to the Smart Charge system. The red wire coming from the plug on the alternator - the battery reference wire, leading to pin 20 on the C90 plug in the main fuse box - was broken inside the loom. I found the break by removing the airbox and visually inspecting the part of the engine loom leading from the alternator to the fuse box (after checking with a multimeter for continuity). This was a pain in the !Removed! and took quite a while. :)


post-55043-0-74423100-1441373982_thumb.j


post-55043-0-44136800-1441373876_thumb.j


I'm still unsure why the Smart Charge system seemed to be working, as seen from the relative voltages with the alternator plug attached and detached.


When I started the thread I mentioned several other intermittent problems. I'll wait for these to happen again, and investigate in due course.


Thanks to those that helped get this far :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this