Sign in to follow this  
ioichrisioi

Can Anyone Help Me Please

Recommended Posts

Hey Guys

I drive a Ford Fiesta 1.2 Zetec LX

When ever I am driving my car suddenly loses its revs, they completely drop to zero and I'm unable to use the accelerator.

this is until I put my foot on the clutch, as soon as my foot touches that clutch the revs are instantly restored and jump back up to where they should be.

there seams to be no rhyme or reason to this as it happens in any gear and in all weather conditions.

any ideas you guys might have for me would be greatly appreciated!

Thank you

Share this post


Link to post
Share on other sites

On some cars they fitted a clutch position switch, check that. Should be a switch on the pedal box.

Share this post


Link to post
Share on other sites

Have a look for a small pipe that runs from the engine block to the fuel injection system this can sometimes block with sludge.

Share this post


Link to post
Share on other sites

I'm assuming it's a petrol...

The coil pack is a common issiue on the mk6.

Also, check the spark plugs as they may be in need of replacement. In addition to this, the spark plug well likes to fill with water that leaks in from around the washer jets. This can be solved by purchasing some Mist type washer jets with rubber seal on them.

Another thing to check is the state of your throttle body.

When was the fuel filter last changed?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this