Jump to content
Do Not Sell My Personal Information


ESP warning light constantly turned on


jack1997
 Share

Recommended Posts

2008 Focus 1.6 Diesel

its been on since i got the car, hasnt really effected driving much but i heard a lot of bad stories. i tried to switch on the esp through the menu in the car and that didnt remove the warning light.

once i replaced the brake pads and the light went off, only to return after i drove the car a second time since replacing.

 

what is the meaning of this?

Link to comment
Share on other sites

1 hour ago, jack1997 said:

2008 Focus 1.6 Diesel

its been on since i got the car, hasnt really effected driving much but i heard a lot of bad stories. i tried to switch on the esp through the menu in the car and that didnt remove the warning light.

once i replaced the brake pads and the light went off, only to return after i drove the car a second time since replacing.

 

what is the meaning of this?

have you got esp switch ? if not you will have to use the elm to turn it on.could be some one turned it off for some reason.

Link to comment
Share on other sites

18 minutes ago, mrmetallica said:

have you got esp switch ? if not you will have to use the elm to turn it on.could be some one turned it off for some reason.

yes in the dash menu there is an option for esp, on and off doesnt do anything.

sorry if silly question but what is elm? does that mean a visit to ford?

Link to comment
Share on other sites

Just now, jack1997 said:

sorry if silly question but what is elm? does that mean a visit to ford?

no not trip to ford .elm is a device for changing settings on the car.there is a lot of threads about it.ive installed the switch on mine so i can just turn it on and off without elm.

 

Link to comment
Share on other sites

4 minutes ago, jack1997 said:

yes in the dash menu there is an option for esp, on and off doesnt do anything.

sorry if silly question but what is elm? does that mean a visit to ford?

you dont need elm then.couldnt remember how it switched on with out the switch.must be a problem then.not sure what it could be.

Link to comment
Share on other sites


Could be down to a problem with the sensor at one of the wheels. I'm assuming the ABS/traction control and ESP all work off the same sensor. Checking back online for my old MOT's I found one from before I owned our focus with the same felt and it is marked down as having the sensor at the wheel changed. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Forums


News


Membership