Jump to content
Do Not Sell My Personal Information


Fiesta idle revs fluctuating


liamc20
 Share

Recommended Posts

I currently own a 58 Plate/2009 model Ford Fiesta Zetec S Ti-VCT 120PS.

Over the last couple of weeks I have had a problem with my idle revs fluctuating up and down when I switch my car on, or when I am sat in neutral. It feels like something is chugging/struggling but cannot pinpoint what the issue is. Took it to my usual trusted garage last Thursday and the car was doing the same when I arrived - however this time the car completely cut out while sat with the engine on for 5 minutes or so. When they took the car into the garage about 15 minutes later, it wasn't fluctuating at the time (surprise surprise). They checked the ECU for error messages but nothing came up, and also did a full service changing the oil/filters and also the spark plugs. The service report came back clear as well.

The issue went away for 4 days but came back again last night. Just wanted to know if anyone had a clue what the issue might be or has experienced the same? I'm stuck with what to do now in terms of getting this fixed.

Any info will be greatly appreciated.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Forums


News


Membership