danuk42

Chirping, squeaking, rattling sound from near side Front wheel area at high speed

Recommended Posts

Hi guys and Gals,

Car is Ford Fiesta LX 1.25 2000 plate. Yup, getting on , done 45, 000 miles, first real problem? I've had. (apart from corrosion lol )

The title says it all. When I start to maintain 50 mph plus along an A road or motorway, I start getting Chirping, squeaking, rattling sound from near side Front wheel area at high speed.

Does it in gear or in neutral , Throttle and no throttle. Just rolls along making this noise.

It calms down a bit when I slow down and get back onto the slow urban roads.

Typical short local journeys to and fro where I don't maintain 50 mph plus I hear no noise.

Any ideas?

Thanks, Dan.

 

Share this post


Link to post
Share on other sites
 

I'm unsure of the layout of the fiesta but my mk4 mondeo is having the same issue which I believe is a rear suspension bush issue. Try lubricating any bushes with a spray silicone lubricant

 

https://www.halfords.com/motoring/engine-oils-fluids/lubricating-penetrating-oil/wd-40-specialist-anti-friction-dry-ptfe-lubricant-250ml?istCompanyId=b8708c57-7a02-4cf6-b2c0-dc36b54a327e&istItemId=-xwwarwarpa&istBid=t&_$ja=tsid:94971|cid:868555909|agid:49387677732|tid:pla-294505072980|crid:203456299629|nw:g|rnd:18253499990739756111|dvc:m|adp:1o5|mt:|loc:9046963&gclid=EAIaIQobChMI5pPz0KLo3gIViLHtCh13WwRtEAQYBSABEgJTUfD_BwE

 

(not normal WD40as this can dry out rubber and cause more problems) might help to narrow down the issue.

 

Hope this helps

 

Sent from my Nokia 7 plus using Tapatalk

 

 

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now