Jump to content
Do Not Sell My Personal Information


Focus MK3 ST TDci - K&N 57s Limp Mode


FocusStMK3TDCi
 Share

Recommended Posts

Hi,

i have installed a K&N 57s into my Focus MK3 ST TDCi however after a min or so the car goes into limp mode. I have checked the filter is fitted correctly and also reset the KAM but still get the same issue. Has anyone got this filter fitted to the same car and got it working?

Thanks

Chris

Link to comment
Share on other sites

This is a known problem of the Focus MK3/MK3.5 with the 2.0 TDCI engine. Many people had this same problem after installing a performance air filter or induction kit on a 2.0 TDCI. 

The increased amount of air going into the engine is basically out of range of the original PCM software. The PCM detects too much airflow and as a result of this assumes there is a problem and reduces the engine power.

Basically there is no easy solution for this problem. You either have to remove the K&N 57S kit and revert to the stock air filter or you have to get a custom remap based on the increased airflow.

Link to comment
Share on other sites

  • 2 weeks later...

Hey, 

thanks for letting me know, i ended up putting a standard K&N replacement filter which works just fine. Thinking of getting PumaSpeeds stage 2 remap towards the end of the year. Might ask them if they can build this into the remap.

Chris

Link to comment
Share on other sites

  • 1 year later...

I had this problem with the 57s but all that I did was put the plug in on the side of the box and since then I have not had a problem with it, shame really sounded better with the plug out but needs must 

Link to comment
Share on other sites

Got this happening on my 1.6 Ecoboost too with the 57s. It only happens a couple of times a year though.I was just going to stick a Ford filter back in, honestly never thought to just replace the bung lol. It does sound great with it out though and the car doesn't feel strangled like it does when I revert back to the standard filter even though the paper element is apparently good for up to 300bhp?

Link to comment
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Forums


News


Membership