Sign in to follow this  
kuepper

Flame 2004

Recommended Posts

Not opened bonnet for a while and today wanted to open it to refill screenwash. I pulled the catch at the side of the front passenger footwell but nothing happened. The catch does seem a bit loose/ flimsy so I don't want to force it but I couldn't feel or hear anything happening and the bonnet doesn't seem to have moved.

Share this post


Link to post
Share on other sites

you need to check if the plastic handle is actually moving the cable or has come detached from it. I have had many cars where the handle has broken and pliers needed to pull the cable (and they were probably all caused by lack of maintenance (oil/grease) on the mechanism under the bonnet)

Also sometimes when the bonnet catch area gets corroded, it can help if someone pushes down on the front of the bonnet, you then pull the lever and hold it out, and then the other person lets go of the bonnet and see if it pops up. Worth a try.   If the cable has come detached from the mechanism at the front end it will be a bit tricky.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this