Jump to content
Do Not Sell My Personal Information


Erratic electrical problem.


PitstopPete
 Share

Recommended Posts

Hello, I have a 2007 Focus style, 1.6, petrol and it has recently having erratic electrical problems. When I turn the key to start the car just before the engine turns over sometimes the windscreen wipers come on for a second or two,  and a warning beep or two or 3.

The other day when I was driving all the instrument cluster lights went on, a few seconds later the lights went off. This has happened a few times.

The other day the temp gauge went to the top when I started the engine, the engine was already warm from driving earlier. The engine was not overheating. Next time I started it it was fine.

The petrol gauge showed empty when I know I had half a tank full. 

The engine cuts out when driving, and when I started it up again it just died, until I start it up and rev the engine. This has happened a few times.

I know a bit about cars and mechanics,  but electrics are not my strong point. I would be grateful for any help or advise. Thanks.

I will clean up any earth connections just in case

Link to comment
Share on other sites


  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




×
×
  • Create New...

Forums


News


Membership