Jump to content
Do Not Sell My Personal Information


2015 1.25 Petrol, Fumes in Cabin


Guest
 Share

Recommended Posts

I've seen this issue crop up a lot on the diesel lumps, also had it on around a 13 plate diesel fiesta, but I've recently brought a 1.25 petrol (65 plate) fiesta and this morning on the way to work I noticed strong exhaust fume smells coming from the interior vents, initially I thought it was something to do with the car in front so pulled back, but no difference, it disappeared after about 10 minutes of me driving with the windows down, then as I went to check it again I couldn't replicate it.

Are there issues with the petrol engines in the same way as a the diesel for causing fumes to enter the cabin?  😱

Car's still under warranty as we haven't had it long,  I just wanted some information initially to see if its a common fault before I go to the dealership as the last fault I described (grinding feeling in the steering wheel when going backwards and now and again when stationary), they couldn't find...

Link to comment
Share on other sites


On 11/26/2018 at 10:55 AM, stef123 said:

You’ve got the most likely answer, a leaking exhaust

Is there any common areas to check? Manifold etc. Cars only done 16K on a 65 plate, can't be corrosion that quickly surely?

I know I did read somewhere that some cars had all but useless filtration systems into the cabin, and I'm fairly certain the fiesta and polo were high up on that list with only 2% being filtered out, I wanted to check out if it's definitely coming from the car before sending it to the garage as without VERY strict information on what to look for they'll get in, say there's nothing there and give the car back and it's wasted time picking up and dropping the cars off. 

 

Link to comment
Share on other sites

Noticed it again last night but not as bad. I can't pinpoint when it's doing it though, because its usually when I'm driving and I put the heaters on warm (without A/C), it could just be throwing the exhaust fumes from traffic in but if its that then the filtration system is doing bugger all. 

I've tried dropping back from traffic and giving more room to see if that helps but it did it again last night, got quite a whiff of exhaust, then it died down - which I think correlated with me changing the vent position from feet & front demist to just front demist. 

There's a few things that need sorting tbh, the idle wobbles on it's own for some reason, will sit at it's idle rpm then drop a bit, then come back, drop and repeat, but it also does it if you hold the accelerator on slightly to just around the same area - so with a completely fixed pedal position i'm seeing the rpm gauge rise and fall slightly and you hear the engine note change as if it's hunting. 

 

Link to comment
Share on other sites

On 11/30/2018 at 7:41 PM, Uncle Tommy said:

Sometimes, there no exhaust leaking, and you smell strong fuel fumes then that cat failure.

At 17000 miles? Shouldn't fail that early surely? 

It might just be passing traffic, but it only seems to happen now and again it's not consistent, I might just change the pollen filter for an activated carbon one and run that instead and hope that deals with it - it's going back in on the 14th for some more work so I'll mention it then. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




×
×
  • Create New...

Forums


News


Membership