John Beranek

Audio update for '12 plate Mondeo not working

Recommended Posts

Having had intermittent bluetooth issues with my '12 plate Mondeo since I bought it, I found information on the Ford audio update, especially the "November 2012" update, as can be found here:

 

Unfortunately when I get to the part where the ignition is turned on, and the update should start...nothing happens.

Does anyone know if this update is supposed to work on a '12 Mondeo?

 

IMG_20190617_214959686.jpg

IMG_20190617_215053685.jpg

Share this post


Link to post
Share on other sites

Wrong radio.
The update only works on sync systems not Visteon Sony head units.

Sent from my SM-G965F using Tapatalk

Share this post


Link to post
Share on other sites

It's down to the bluetooth module which is seperate to the radio.
Not sure where it is on a Mondeo but it will be bolted up under the dash somewhere.

Sent from my SM-G965F using Tapatalk

Share this post


Link to post
Share on other sites
1 minute ago, John Beranek said:

Oh, thanks! I'll give this a go.

Oh, that's exactly the file iNath posted about in these forums, and didn't work in my Mondeo. ☹️

Share this post


Link to post
Share on other sites

ah right. 

Have you made sure you've unzipped the file and put it in the root of the USB stick (with nothing else on it)?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.