creativityvas

Mondeo mk3 sunroof cable lost it's way

Recommended Posts

Hello mates,
new to the forum so sorry if i missed some rules... Bought a mint condition mk3 with 2,0 tdci, ghia with a non functioning sunroof. The problem is that the motor itself works, but doesn't move the sunroof. Sunroof is in kinda little bit opened position, and i cannot close it. Took out the motor, to find out that everything is ok with the motor. And then i stumbled upon that the cable, which the motors cog wheel moves, is moving like a snake out of it's place... So i have this lose piece of cable as in the picture, don't know how to make everything work. Tried to put it back in the little pipe where it travels it's way while tightening the motor manually, it did place the cable in place, but it still doesn't move the sunroof, nor then does the cable move if i put it in place... Hope you understand me, ask questions if you want, i have to drive this thing tommorow and it's raining as hell..

71336155_396000271045877_6170089539999105024_n.jpg

71837332_458239861707141_164669991021445120_n.jpg

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.