Jump to content
Do Not Sell My Personal Information


I have this message " front light malfunction" ford mondeo 2010 mk4 titanium x tdci 2.0


Recommended Posts

My Mondeo has xenon lights, anyone had this issue? dashboard message "front light malfunction" all lights seem to be working fine unless I am missing something?, any help would be apprieciated.

Link to post
Share on other sites

No offence intended, but are they definitely xenons? The adaptive lights and xenons look almost identical from the outside so it's very easy to mistake one for the other.

That message popping up when all the lights are still working is usually down to the adaptive lights failing and no longer swivelling left and right as you corner.

Link to post
Share on other sites

Hi. no offence taken,  your description sounds spot on tbh,  your description is exactly what is happening, have you any idea what I need to do?

Also, I am not getting the message all of the time, so would I be correct in thinking that there is a wire loose? I am thinking that if there was something seriously wrong it would be all of the time?

 

 

Link to post
Share on other sites

If you look at the headlights projector lens they are in a surround. On xenons the surround is circular to match the lens but on adaptives the surround is slightly oval to let the lens move left and right.

 

Mine used to do it quite often, usually every time I had to make a right turn. They'd start turning right then ping back to centre and put the warning on the dashboard. After driving for a few minutes I'd see the light's do the left right swivel as if they'd just been turned on and they'd work ok again....until another sharpish right turn.

In my case it was some corrosion in the wiring plug, I removed the headlight, unplugged it and got some fine sand paper into the connector on the headlight to clean up all the contacts as they were rather crusty and blue. Sprayed some electrical contact cleaner into both the wiring plug and the headlight plug and then dried them off with a hairdryer.

Touch wood after 4 years they're still working.

Link to post
Share on other sites

Thank you for the info, I shall give that a try, they are a lot worse this evening, the malfunction stayed on continuously, never had that before, I stopped turned engine off, and back on, but made no difference, at one point the left light was pointing to an extreme left as if I was going round a corner but wasn't.........I shall take the lights out and have a look at the wires, thankyou 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Forums


News


Membership