Sign in to follow this  
Samwell

Mpg Guage - Tdci's. How Quickly Does Yours Rise Up From 0?

Recommended Posts

Hello all

Since recent injector/diesel issues, I was wondering if it was me.. or the car.

Before, Im certain my MPG guage could go from 0 to 45 (ish - ive got to 57+).

Now, Ive travelled 30-50 miles tonight from 0 and after this time, mostly all on dual carriageway at 60/70mph, the guage has got up to 27mpg. Still rising but damn thats super slow right???

Can anyone tell me what they've seen theirs do when checking out MPG?

*P.S - is it injector/diesel problem time of the year or WHAT right now?!

Share this post


Link to post
Share on other sites

Where is the mpg gauge. I'm unsure if mine has one lol

Share this post


Link to post
Share on other sites

IF HE HAS A GHIA HE MIGHT HAVE A TRIP COMPUTER.

i DON'T HAVE ONE IN MY ZETEC S, UNLESS THERE IS SOMETHING I DON'T KNOW ABOUT.

Share this post


Link to post
Share on other sites

Hello

Yes, I have a 2002 TDCI Ghia X with the trip computer. I wasnt aware non-Ghia models didnt have the computer??

I have re-set the MPG guage, but it was probably running on 0 anyway as Ive had the car started lots and sat without moving because of the injector issue.

I was certain that in the past, before my injector issue, it would take only 5-10 minutes from a 0 reading to reach 45 mpg average, not even motorway driving! Perhaps its just really bad diesel in the tank... humm.

Share this post


Link to post
Share on other sites

I have the same problem when i zero the mpg button if going on a long run it goes from 99mpg and counts down fast and settles around between 23mpg to 33mpg im pretty sure its not working correctly ive also notice it tells me ive 108miles left in tank but the fuel gauage sits on red then all of a sudden the clock drops to 50miles or less in the tank and the fuel light come on. then goes off and back up to 100miles left :unsure:

but ive notice when anyone gets out of the car you get a static shock could it be theres a bad earth on the car causing this or is it just me it feels a bit like when your clothes come out the tumble dryer and is full of static its probly just me but does anyone have this sort of problem :wub:

john

Share this post


Link to post
Share on other sites

If I zero mine it settles down quicklyby the time ive done 10 mileson an A road its showing 45ish, but this is a very fragile reading if iI accelerate it will drop to mid 20's, it atkes a fair few miles to get a reading that is steady, remember this is an average consumption reading not a real time reading currently done 565 miles since I have reset, this is mainly 40% A road and 60% town journeys of less than 5 miles (been a lazy sod) and my average is 44.3 mpg according to the computer not done a real world check for a while.

Just a thought, are you looking at average speed instead of MPG, cos speed takes a long time to build up.

Also mine only shows a zero rading very briefly , time and mileage controlled but about a mile I think

Share this post


Link to post
Share on other sites

My average seems to be creeping up very very slowly, I think it HAS to be something with the fuel quality/additive used.

Definately looking at MPG reading. The speed reading usually stays below 10/20 mph. Fuel tank level is dropping progressively (journeys between 5-20 miles a couple of times a day). Remaining mileage on tank level (at 3/4 full) says about 200 miles.....!!!! *worried face*

Share this post


Link to post
Share on other sites

*Tonights update.*

Decided to go on a 100 mile dual carriageway/motorway mix drive. Managed to get from 26mpg to a now 39mpg. Better, but still struggling SO much to reach any more! You'd think driving on a motorway for 20 mins should show some vaster improvement than this! Seeing as when I first got the car about a month ago, I was getting almost 60mpg and averaging at 45 on short journeys.

Something aint right.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this