Jump to content
Do Not Sell My Personal Information


Sprinted Drive. No Brake Problem


AJRTDDI
 Share

Recommended Posts

i was on a sprinted drive coming out of my works grounds. i got alittle liftoff oversteer and snapped it back. around 5 mins later.

I lost all my brakes and have a soild pedal.

what should i check first ?

Link to comment
Share on other sites

i had all new brake lines.
New fuild
New disks
New pads

4 months ago.

only recent thing iv done was head rebuild due to cambelt. Maybe breather pipe damaged dueing rebuild ?

Link to comment
Share on other sites

i had to really stand on them to slow down even alittle bit.

I blowed down the pipe /sucked and 1 way valve seems to work fine . i didnt feel any damage to the pipe.

after sucking hard on the vacume pipe is seemed like there was alittle fuild in there.

i changed the vacume pump.

(pumped pedal then started and pedal did slowly go down.. but really slow. i cant even find the dam servo all i know is im due in work in less then 30 mins and im sick of this car breaking ever 5 seconds.

Link to comment
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Forums


News


Membership