Jump to content
Do Not Sell My Personal Information


Please Help!


ash90
 Share

Recommended Posts

My car is over revving on its own without accelerator being pressed and picking up speed on its own when I switched it off it had trouble starting back up then after about 30minutes it started no problem. The car drives fine for about 5minutes before it starts revving and picking up speed. Any idea of the problem please?

Link to comment
Share on other sites

Throttle position sensor most likely or Idle Air Control valve sticking - take it out and give it a squirt and a clean with WD40.

Remove the TPS connector wire and see if it fixes the problem - if it does as I suspect it will then its the TPS.

Link to comment
Share on other sites

I have found the part to buy for throttle position sensor but after looking under the bonnet it looks as though the part is very concealed in. Any tips on how to change this cannot find any help videos for a 2006 ford ka

Link to comment
Share on other sites

I removed mine a few weeks ago - wasnt that difficult although my car is a Streetka.

Not sure how different the engine is to be honest but all it took was to remove the throttle body (4 screws) and air box and pipe to get into it.

Removal was then simple.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Forums


News


Membership