Jump to content
Do Not Sell My Personal Information


Hello


xr4s r ace
 Share

Recommended Posts

Hi Guys, have just acquired a 2003 1.3 Ka for my son to learn to drive. It has a few issues, useless brakes, the odd leak here and there, the major one is a water leak. There is a not very nice noise from the left side of the engine and a drip so i presume its the water pump...is it a reasonable fix?. The other thing is the heater only blows cold air, the pipes to the matrix are getting very hot both sides so i dont think their is an air lock problem. Have checked the back of the heater control panel and i cant see any way that the temp is controlled by the dial. Any advice would be very well received. Cheers pete

Link to comment
Share on other sites

Heater issue is a common one is down to the heater control valve sticking.

Water pump removal - not done it yet but its supposedly a tricky one!

Search the forum all your answers with photos and diagrams are already been answered before.

Thats why its essential to read the faqs first before you post!

 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Forums


News


Membership