Jump to content
Do Not Sell My Personal Information


Ford Fiesta Mk6.5 Clutch Clicking


jakenib
 Share

Recommended Posts

Hello,

I've got a Ford Fiesta mk6.5 (57 plate) and have been having click in the clutch pedal the last few days. I took at look at it earlier and it seems that a rod isn't secure and when the clutch is compressed the rod moves along the connector causing the clicking noise. Is there meant to be something that securing the rod in place?

Cheers

thumb_IMG_1033.jpg

IMG_1033.jpg

Link to comment
Share on other sites

 My old mk6 i had snapped,it kept slipping off the spline and also clicking trying to adjust itself so took it to ford and on the recall put

another kit on it,found out the person who had it before put a cable tie around it and onto the black piece and twisted it and snapped.

Had to jam it into gear and start it up in gear to drive then AA job.

Link to comment
Share on other sites

22 minutes ago, jace1969 said:

 My old mk6 i had snapped,it kept slipping off the spline and also clicking trying to adjust itself so took it to ford and on the recall put

another kit on it,found out the person who had it before put a cable tie around it and onto the black piece and twisted it and snapped.

Had to jam it into gear and start it up in gear to drive then AA job.

So do you know if Ford would repair this for free or would it include a standard charge?

In the mean time what would you recommend to keep it in place?

Link to comment
Share on other sites

There was a recall for the earlier ones but yours looks like a later clutch pedal with the longer shafts. The clips that were fitted are about 20p to buy and fit it yourself. Cable ties were the original fix Prior to recall

Link to comment
Share on other sites


I should say you would have to pay,see mine went as in snapped,it did come off and got very close but the stupid person before didnt

only put the cable tie on the spline/rod but around the plastic so when it moved it use to bend it.

I should ask them see what they say.

Link to comment
Share on other sites

Thanks for the replies, the cable ties pop off every time I depress the clutch. Going to get a locking washer as I've seen that they work and are more of a permanent fix

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Forums


News


Membership