Jump to content
Do Not Sell My Personal Information


sewerage smell in reverse, Tit X 125 ecoboost


rossierose
 Share

Recommended Posts

Hi, would appreciate some advise please if possible. Had my 65 plate titanium X ecoboost 1L / 125 for nearly 7 days and done just under 200 miles so speedo  now 1700 miles.  Over the last few days I noticed every time I use reverse I get a horrible sewerage/ bad eggs /sulphur smell in the cabin and the car judders and creaks its way back  (that may be be due to me not revving hard enough I suppose - I'm not used to it yet, having driven a diesel for last 5 years!). I have  also found that the clutch feels juddery at times in forward gears . I checked the forum for previous answers and althoughbad smells have  been mentioned, no solution seemed to be evident. Is this normal for this type of car or do I need to take it back to the dealer? I didnt experience any of these problems with my 1.6 diesel so am not sure if I just need to get used to driving a petrol again ? would appreciate some reasurance! many thanks.

 

Link to comment
Share on other sites

It's just the catalytic converter.

By going backwards you are probably driving in to your exhaust trail.

It smells more when new until it has settled in a bit, and it will also smell if you have been driving the car hard.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Forums


News


Membership