Jump to content
Do Not Sell My Personal Information


No front wipers, back wipers or washers


scooterist007
 Share

Recommended Posts

Hi there, my wife has a fiesta 1.4 petrol 2005, and the wiper stalk has stopped working, no front wipers, no rear wipers and no front and rear washers, now I went to the local scrap yard and bought another wiper stalk and fitted it, but it still doesn't work. Anyone any ideas?

I do have forscan, can this point me to what might be the problem?

 

Regards

Link to comment
Share on other sites


Fuses or relay would be my guess. Not sure Forscan would be much help for something like this. Nothing senses when the wipers stop working other than the driver an MOT tester lol.

Link to comment
Share on other sites

Well I did a night shift last night and I thought I would give the fuses a look, the front screen fuse I took out, it was quite tarnished, so I cleaned it up, put back in and they started working! So one fuse stops everything working even though the rear wiper has it's own fuse!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




×
×
  • Create New...

Forums


News


Membership