Jump to content
Do Not Sell My Personal Information


Ford Fiesta Mk7 Multiple ECU errors - won't start


Sarah_m12
 Share

Recommended Posts

Hi everyone,

I am new here so I apologise if this is posted in the wrong place. 

I am after some advice on ecu errors for my 2013 ecoboost please. Yesterday I was driving along no issues what so ever, then suddenly car just coughs a few times and comes to a complete stop. Engine malfunction popped up and service now,  then went completely dead except for the electronics, engine will not start at all. I disconnected the battery to reset it all and nothing. Took it to the garage today and there were tons of ecu errors all unrelated. They wiped them and the car started fine, only cut out again minutes later, so they wiped it again and it would not start at all. Has anyone experienced this? Or have an idea of what it could be? 

 

Thanks

Link to comment
Share on other sites


They are calling in an auto electrician who traces fault codes back, because there are so many and they don’t relate to each other. He will be taking a look on Monday, I’m just dreading it’s the ECU that could have failed?

Link to comment
Share on other sites

  • 2 weeks later...

I had the exact same problem with mine, It was the fuel pump on the engine(not in the tank). I was getting zero fuel pressure in the very cold weather, sometimes it was fine others it would not start.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




×
×
  • Create New...

Forums


News


Membership