Jump to content
Do Not Sell My Personal Information


coding GEM or other with Cruise Control swap


vlakci
 Share

Recommended Posts

Wanted to put cruise control, but I came to a dead end. The car is a 2007 MK2 Ford Focus EU LHD Manual (front windows, power steering, normal radio, low HEC).

- I have the wires between GEM and Steering Wheel

- I can code with ELMconfig the cruise control option in HEC and PCM

- the GEM is the basic one 4M5T....Ax, cruise control can't be coded, also beep test with cruise control steering buttons doesn't work

 

I can get a low cost  3M5T....Cx from a same market C-MAX and test it before paying it, but I have problems with the immobiliser. I coded to donor GEM the VIN, page1, page2, page3 from my GEM as to first to "clone" my setting from the old GEM to the second, but then the car doesn't start any more. What else do I have to code/change with Forscan or ELMconfig to get the car running before checking if this GEM will do OK with all the other functions of the car plus cruise control? For now I have placed the old GEM back in the car and engine starts normal as before.

Link to comment
Share on other sites


Is maybe the problem as I have to re-program the key fobs on both keys and lock-unlock the car? From what I read on an other forum the PATS is only concerned with HEC and PCM, which I didn't change.

Quote

GEM swapping - if so, you don't need to program PATS. Only IC and PCM are involved into PATS on Focus Mk2.
However, you would probably need to transfer configuration from old GEM to new one (or load AB data from Motorcraft site), and program your keyfobs to the new GEM.

 

Link to comment
Share on other sites

1 hour ago, vlakci said:

 I coded to donor GEM the VIN, page1, page2, page3 from my GEM as to first to "clone" my setting from the old GEM to the second, but then the car doesn't start any more. What else do I have to code/change with Forscan or ELMconfig to get the car running before checking if this GEM will do OK with all the other functions of the car plus cruise control? For now I have placed the old GEM back in the car and engine starts normal as before.

…. you should be able to copy all the 3 config pages to the different GEM and it should work...

check the fuses are ALL the same... I did mine (in a rush) and there was no fuel pump fuse !!!!  nothing wrong with the way I fitted or coded it (I think diesels don't need that fuse) its 15 or 20 amp forget number

 

when you said you can't code CC why not ? grey out / not there? on one its called integrated speed control or something

Link to comment
Share on other sites

in other cruise control DIY topic it says that for cruise control you have to have a Dx version of GEM and some also managed to get it on Cx. If I read GEM -> put flag on CC -> write to GEM -> read from GEM the flag goes out - so I deduced that is a function which isn't possible on the 4M5T...Ax. Also the "beep" test doesn't give a response when CC buttons pressed but steering wheel and wires are all good.

About the fuses I gut the same idea yeasteday evening as the donor was diesel. I didn't pay attention as the factory GEM has only a few used and the donor has almost all inserted, but didn't check if any one missing. I will recheck after work.

Link to comment
Share on other sites

CC working. The GEM 3M5T...Cx from a 2003 CMAX was without petrol fuse 51 and relay 4, that fixed car starts. The PCM was coded (21+5min) and also HEC (1min) for the CC

 

I noticed an annoying feature. The HEC green light for CC lights up only after PCM holds speed - there is no visual info that CC is in "stand-by". If by mistake at 50km/h first "ON" on steering wheel and later also by mistake "+" it will start holding speed without the driver being prepared that CC will hold speed. With e.q. BMW >97' the instrument cluster has light that shows cruise control already in "stand-by". Is this missing Ford feature only with low units of Focus MK2 HECs (only small screen for speed/temp/avg/range...)?

Second about the threshold speed:

- 30km/h + wheel "ON" -> will CC go in "stand-by" or remain "un-active"?

- 60km/h + wheel "ON", CC is in "stand-by", later speed lowered to 30km/h -> will CC remain in "stand-by" with waiting threshold speed (40km/h) or go in "un-active" (same as wheel "OFF")

Link to comment
Share on other sites

I can only speak about my Mk3. I don't know if the Mk2 would be the same. I guess it's likely that different versions of the software will give different displays.

Anyhow, with my CC when it's first activated into standby before a speed is set the display remains blank. After a speed has been set it's displayed at normal brightness and is held. If the CC is then put into standby (by operating the 'cancel' switch, brake or clutch) the speed is no longer held and the speed display is greyed with a bar drawn through it until re-activated by another operation of the 'cancel' switch.

Link to comment
Share on other sites

3 hours ago, vlakci said:

CC working. The GEM 3M5T...Cx from a 2003 CMAX was without petrol fuse 51 and relay 4, that fixed car starts. The PCM was coded (21+5min) and also HEC (1min) for the CC

 

I noticed an annoying feature. The HEC green light for CC lights up only after PCM holds speed - there is no visual info that CC is in "stand-by".

 

great news..... CC instrument light is only lit when holding speed.... real cars don't need the nanny, I don't want a lets waste my life and press a button so I can press another button to hold the speed.  It must be some euro safety garbage.

the brake pedal turns it off, who cares if you had previously set at 150kph and press the button at 30kph (if it had 650bhp and I was 89 years old it might matter, as it has about 100 its not ever going to be a Biggy)

on my last four cars CC was always active, ready to hold the speed whenever turned on - as it should be - driving the focus at night is a mission to work out what to press when

FYI my current car you can set the speed at 190kph stop and you can just flick the lever from stationary to go back to set speed.... marvelous 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




×
×
  • Create New...

Forums


News


Membership