CarlThePlasterer

ford fiesta brake problem

Recommended Posts

I have a 2017 fiesta zetec 1.0 ecoboost auto and i have a brake problem that i've been unable to diagnose.
basically when the brakes are applied there is an intermittent squeak/rubbing....cars been in garage, brakes checked out fine, suspensions been checked and fine along with some other stuff as well

The garage has done everything to try and find what the cause is but even they are at a loss also.....can anyone PLEASE help and give me some idea of what could be causing my issue?
tia

Share this post


Link to post
Share on other sites
 

Probably when the brake pad "ears?" rub on the metal clips holding them in. Usually a quick strip down, clean, and new copperslip applied limps them along. The pad can sometimes rub on the lip on the brake disk, you can easily remove that by turning the wheels around (I'd use the engine running in first gear to do that, but not everyone will be so keen) and running a grinder over the lip. Maybe even take some rough emery paper and give the pads a quick once over to toughen them up if they have gone shiny.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.