Sign in to follow this  
CraigJ123

Volume buttons on steering wheel not working Fiesta 2012

Recommended Posts

Hi. My dad gave me the car a couple of weeks ago and I keep forgetting to query it but for some reason the volume down button doesn't do anything and the volume up button only changes the radio station and nothing when playing music. Any ideas?

Share this post


Link to post
Share on other sites

Hi I would suggest gently lifting the button up and giving the contacts a light spray with contact cleaner through the gap. 

Share this post


Link to post
Share on other sites

mine has similar problems but intermittent in what does what. sometimes it all works correctly (rarely) sometimes left and right buttons work but not up and down, sometimes volume will go up but not down etc.  it changes every few days. has done since the car was about a year old. perhaps you will find yours changes every now and then. personally I don't mind using the controls on the front of the radio except there is no voice control button on the radio itself and the voice control button on the steering wheel is the most unreliable of the buttons on mine.

Share this post


Link to post
Share on other sites

I'm using a USB memory stick with songs I downloaded to. Some songs are quite different in volume levels and having a previous Focus, it had the volume next to the wheel or a big dial so it's a big change and a lot more fiddly. It seems more like a settings thing but could be wrong.

Share this post


Link to post
Share on other sites

Had the same on my 2011 Fiesta, had to get replacement buttons from ebay, seems to be a common issue

Chris

Share this post


Link to post
Share on other sites

I had the same problem on mine and I read on here that someone had success bu banging the steering wheel in the switch area, i tried this and the buttons work normally for quite a while afterwards. They still play up every now and then but another thump seems to correct them.  

Share this post


Link to post
Share on other sites

I gave it a bang and also blew around the sides. It now works. Thanks. I did have a little go at trying to take the panel off. Glad I didn't after watching an auto repair video stating you have to disconnect the battery first which makes sense.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this