Sign in to follow this  
TomsFocus

Android SD Card Issue

Recommended Posts

I posted this in the don't like thread a few weeks ago but still haven't found a fix.  Have barely taken any pics over lockdown so hasn't been an issue but want to sort it now.

After a recent system update, the 'Photos' app doesn't have permissions to access the SD card...so I can take photos and store them on the SD card with the camera, but then can't delete or edit any of the photos through the phone at ll.

I've tried a few fixes I found online, trying to reset permissions in apps etc, but nothing has worked so far.

So, question is, if I pull all of the photos from the card and onto the laptop today, how can I make the phone think it's getting a new SD card, so it's forced to ask for all of the permissions again?  I'm hoping there's one hidden somewhere that I've been unable to find.

Cheers,

Tom

Share this post


Link to post
Share on other sites

Which photo app are you using, is it a stock android app?

What phone and what OS are you running?

You could try removing the the pics like you said and then reformat the card.

Share this post


Link to post
Share on other sites

It's a Motorola One, latest update was Android 10.

Photo app is either stock Android or stock Motorola, I haven't changed it from new lol.

 

Share this post


Link to post
Share on other sites

Try deleting the "Photos" app, or removing updates from it. It'll be in app settings somewhere. I had the same issue last year with my Huawei P10, I removed updates from Gallery and cleared it's storage, cache, etc. Then re-launched Gallery and it re-populated correctly showing SD card DCIM and allowing movement between phone and SD card storage.

Screenshot_20200603_135402_com.android.settings.jpg

Share this post


Link to post
Share on other sites
32 minutes ago, The_Imaginative_Lad said:

Try deleting the "Photos" app, or removing updates from it. It'll be in app settings somewhere. I had the same issue last year with my Huawei P10, I removed updates from Gallery and cleared it's storage, cache, etc. Then re-launched Gallery and it re-populated correctly showing SD card DCIM and allowing movement between phone and SD card storage.

Screenshot_20200603_135402_com.android.settings.jpg

Thanks!  It does seem to be a common issue but none of the solutions I've found online have worked so far.  It won't let me delete the photos app but I'm now trying find out how to remove updates!

Share this post


Link to post
Share on other sites

Finally fixed!! :biggrin:

Removed updates, cleared storage & cache.  Reinstalled updates.  Took a photo and tried to delete it - that gave me the option to allow or deny access to the SD card. :smile:

 

 

Share this post


Link to post
Share on other sites

Hmm, not quite as fixed as it thought! 

I can now delete stuff, but I can't save editted images...any ideas? :unsure:

 

Share this post


Link to post
Share on other sites

After you edit a picture what options do you have? Can you screen shot a picture that you have edited and show us?

Share this post


Link to post
Share on other sites
2 minutes ago, Jonro2009 said:

After you edit a picture what options do you have? Can you screen shot a picture that you have edited and show us?

I just hit 'save'...but it fails to save and shows the message below:

Screenshot_20200603-200025.thumb.png.d79e3be605ab2869c0e1802781df98a8.png

 

Interestingly, it will save an editted image from Google Photos online storage, one that I deleted from the SD card earlier.  Just not the photos I've taken since...but I can delete those photos. :unsure:

 

 

Share this post


Link to post
Share on other sites

If you turn off Google photo storage temporarily and try to edit and save then, will that work?

Share this post


Link to post
Share on other sites

14 hours ago, Jonro2009 said:

If you turn off Google photo storage temporarily and try to edit and save then, will that work?

I can't work out how to do that?

I think the photos app is actually Google now rather than Android or Motorola.

Edit - Looks like another common issue!  You'd think Google could make an app that works lol!

https://support.google.com/photos/thread/47959695?hl=en

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this