Mikeh

Is it limp mode or do I have a speed limiter fitted on my van ?

Recommended Posts

I am trying to sort out a 2013 1.5 Fiesta diesel van.  It accelerates well and drives perfectly up to 75 MPH. It will not go above 75 MPH though can achieve that speed in 4th or 5th gear (not tried 3rd).

This feels to me more like it has a speed limiter fitted or programmed into the ECM than going into limp mode.  75 MPH seems too fast for limp mode and presumably the revs are going higher in 4th gear than 5th and I think limp mode actually limts the RPM. 

It does have 2 stored DTC codes P2599 and P0299 - these may be old codes, I haven't  tried to clear them yet with my cheap ODB2 reader.

I have filled it with Shell Advanced Diesel and Wynns Turbo cleaner just as a start.

Any ideas before I sacrifice my credit card at the local Ford garage ?

Where are the good turbo specialists near me within in Redhill ?   

Share this post


Link to post
Share on other sites

Check that you don't have a MyKey set up with a speed limit? 

Share this post


Link to post
Share on other sites

It let's you assign speed limits and stuff onto specific keys, so if you lend the car out you can limit what they do with it. Not sure if the vans have it but the car Fiestas do. 

Share this post


Link to post
Share on other sites

Just Googled MyKey and it isn't in operation on my van.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.