Jump to content
Do Not Sell My Personal Information


Where is the Glow plug relay


Recommended Posts

Where is the glow plug relay on the 06 S-max 2.0 Tdci. its showing as a fault on a Snap-on scanner, along with the plugs themselves which have been changed and MaF Sensor which has been changed also. all i need is to find and replace the Relay/control unit for the Glow plugs and can not find it. Help please.

Link to post
Share on other sites

Hi Dan, I will take a look and see if I can find some pictures that might help. Give me a couple of hours

 

Link to post
Share on other sites

Hi Dan, have you seen the post in the S-Max forum called

Glow plug rely

Search for that - yes it is spelt wrong. Posted August 26 2020 by James Shepherd.

Follow the thread it might well help.

 

Link to post
Share on other sites

57 minutes ago, danialhunt said:

Are any of these built in to the PCM? 

Very unlikley to be in the PCM, More likely in the engine bay fuse box. Have you checked out this info, I am assuming a Mk3 Mondeo will be very similar, though the Mk4 came in about 2007.

 

Link to post
Share on other sites
22 minutes ago, Tdci-Peter said:

Very unlikley to be in the PCM, More likely in the engine bay fuse box. Have you checked out this info, I am assuming a Mk3 Mondeo will be very similar, though the Mk4 came in about 2007.

 

Yeah all relays in the fuse box have been checked. I can’t find the glow plug control module so I’m thinking it’s controlled by the PCM

Link to post
Share on other sites

Hello Dan, there are two fuses, a relay and a control module for the glow plugs on your S-max so it would seem acording to this YouTube video:

F2 - 5Amp    F4 - 60Amp

 

Link to post
Share on other sites

Dan, I can't quite make it out for sure but it looks like I can see the relay control on one of your photos (see below)

Relay.JPG

Relay Glow Plugs.JPG

Link to post
Share on other sites
2 hours ago, unofix said:

Hello Dan, there are two fuses, a relay and a control module for the glow plugs on your S-max so it would seem acording to this YouTube video:

F2 - 5Amp    F4 - 60Amp

 

I have found the fuses and the relay but can not find the control module. 

Link to post
Share on other sites

Hi Dan, was the relay the one I posted with the Red arrow on the photo? 

The relay you found was it like the one in my last post? 

Link to post
Share on other sites
On 4/19/2021 at 12:20 PM, unofix said:

Dan, I can't quite make it out for sure but it looks like I can see the relay control on one of your photos (see below)

Relay.JPG

Relay Glow Plugs.JPG

I’ll get a better photo of the area

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Forums


News


Membership