Jump to content
Do Not Sell My Personal Information


Recommended Posts

 

Hi, please can anyone shed any light on the following issue on my 07 Smax. When the fuel tank is just over 1/4 to 1/2 full the digital miles left on the dash start jumping around and then decrease to 0 miles left within 5 to 10 mins, this then shuts the car down as the computer is telling it there's no fuel in it. The 1st time it did this the car was left an hr whilst waiting to be recovered, however when the ignition barrel was turned to 2nd position there was x amount of miles left again.. diagnostics reader from recovery didn't detect any error codes. When the miles left drops to 0, so does the fuel gauge, all other gauges work fine.

I have thought it could be sludge in the bottom of the fuel tank covering the fuel sensor, however not sure if it could be something else with the fuel filter/pump. Any help or advice greatly received before I tackle the fuel sensor in the tank.

Thanks you in advance. 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Forums


News


Membership