Jump to content
Do Not Sell My Personal Information

Auto start not working


Roger Haywood
聽Share

Recommended Posts

Auto start not working, switch not lighting with ignition. Could this be due to low battery?

Link to comment
Share on other sites


2 hours ago, Roger Haywood said:

Could this be due to low battery?

In a word "Yes"

Charge the battery for at least 8 hours. Make sure that you connect the negative lead of the charger to the main chassis earth point - NOT to the battery negative

Link to comment
Share on other sites

18 hours ago, Roger Haywood said:

switch not lighting with ignition.

? Switch normally only lights up when you press it to disable stop/start.

  • Like 1
Link to comment
Share on other sites

5 hours ago, Eric Bloodaxe said:

Switch normally only lights up when you press it to disable stop/start.

Very true. It's inverse logic !!

Lights up to tell you it's 'OFF' - talk about confusing聽馃ぃ

  • Like 1
Link to comment
Share on other sites

Latest Deals

Ford UK Shop for genuine Ford parts & accessories

Disclaimer: As the club is an eBay Partner, The club may be compensated if you make a purchase via the club

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

聽 Pasted as rich text. 聽聽Paste as plain text instead

聽 Only 75 emoji are allowed.

聽 Your link has been automatically embedded. 聽聽Display as a link instead

聽 Your previous content has been restored. 聽聽Clear editor

聽 You cannot paste images directly. Upload or insert images from URL.

聽Share






  • Create New...

Forums


News


Membership