Jump to content
Do Not Sell My Personal Information


Windscreen wipers not working


Connor94
 Share

Recommended Posts

Hi all, looking for a bit of advice.

My wind screen wipers are not working at all. Washer pump is working and all fuses have been tested ok. I have replaced the motor and the switch still to no avail. Next thing to check is the BCM before I go ahead and do this is there anything I should check? Can anyone provide a wiring diagram?

Cheers in advance,

Connor 

Link to comment
Share on other sites


6 minutes ago, Connor94 said:

Washer pump is working and all fuses have been tested ok. I have replaced the motor and the switch still to no avail. Next thing to check is the BCM

My goodness that's a lot of work !!

I would recommend downloading FORScan (it's free for use on a laptop) and buy the new 'vLinker FS' connecting cable. Then you most probably will be able to diagnose the fault quickly and without the need to guess which is expensive and time consuming.

FORScan: https://forscan.org/download.html

vLinker FS connection lead : https://www.obd2shop.co.uk/wholesale/vgate-vlinker-fs-elm327-for-ford.html?gclid=CjwKCAjwpKyYBhB7EiwAU2Hn2ckEMPZgWytToAd3yCV3qQFVSzH_JvjJGXAtiGa3dWRbnXfK1qHDaBoC4J0QAvD_BwE

Link to comment
Share on other sites

I know it’s easy to say this:  before you replaced the motor did you check if there was 12 volts on the wire to it?  Presumably there wasn’t 12 volts on the relevant wire and therefore replacing the motor wasn’t going to fix it.  On my brothers 2008 focus the wipers stopped working. The fault was within the bcm. In the end I rewired supply to motor with a toggle switch next to the heated rear window switch so the bcm had no involvement in the wipers. Not ideal but it was certainly easier and cheaper than fixing it properly. My fix would not be to everyone’s taste I admit.  But at least it meant the car was usable and mot passable

Link to comment
Share on other sites

Thanks unofix, I have now run the diagnostics and been given the following error code from the bcm “B1C53 - Front wiper Intermittent data

 

Additional fault symptom: Open Circuit”

 

Any idea what the next move is?

 

thanks in advance

Connor

  • Like 1
Link to comment
Share on other sites


Here @Connor94 is a link to my private Google drive with the fiesta wiring schematics

On 8/31/2022 at 8:03 PM, unofix said:

Wiring schematics for Fiesta

Mk7 - 2012 onwards

2017 - 2020

2020 - 2021

https://drive.google.com/file/d/1TZZeRYoX_6lTXN_tS6ZfEuN2dHhdt6SR/view?usp=sharing, https://drive.google.com/file/d/1ghvIf0WBn6SYTqdf2biBR9qs3kPwb4Zs/view?usp=sharing, https://drive.google.com/file/d/1qalYB5510zbnJfwtpTsbyYiFK2U3HUgB/view?usp=sharing

 

I will leave these available until 8th Sept 2022 for anyone who may have a need of them.

 

Link to comment
Share on other sites

As you will see from the schematics the wiper motor is controlled from the BCM.

First I would disconnect the negative lead from the car battery.

Then remove all plugs from the BCM and even remove the BCM from the car. Inspect all connectors and pins for any signs of corrosion and/or water ingress.

Check the circuit board of the BCM for signs of greenish corrosion. If every thing looks OK then use a multimeter and start checking the wiring from the wiper switch to the connector of the BCM. Look for either high resistance or open-circuit in the wiring.

Link to comment
Share on other sites

Hi Unofix, okay so i have got a new BCM and the wipers are now working. I have taken a back up of the configuration of my old BCM and when i go to load it to the new one it says there is a "configuration structure mismatch". Does this mean i have ordered the wrong bcm replacement? My old one had 13 hex blocks and the new one as a lot more?

Cheers,

Connor

Link to comment
Share on other sites

That sounds like you have the BCM for a higher spec model. What is the full part number of both the old and new BCM 

Link to comment
Share on other sites

Old BCM DN1T-15K600-CE

New BCM AV1T-15K600-GH

Apologies i'm pretty new to all this - take it I need a like for like replacement?

 

Cheers,

Connor

Link to comment
Share on other sites

Is there anything that is not working?  If it’s all working properly what’s the worry? 

Link to comment
Share on other sites

Hi isetta, yeah central locking not working now. I'll need to properly test everything out first but FORscan shows that the BCM is not compatible.

 

Cheers,

Connor

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




×
×
  • Create New...

Forums


News


Membership