Sign in to follow this  
big col

Engine Stalls On 97 Escort Ghia

Recommended Posts

hi all...my car just passed its m.o.t re-test after i replaced the lambda sensor...however, after i had driven it home, i went out in it again about 2 hours later...when i started the engine, it reved then died!, i tried again and it did the same, on the 3rd attempt it just managed to kick in...i also had occasions when the rev-counter went up and down a few times then stalled...today i stopped at lights and she stalled!, first time this has ever happened..in fact,i have NEVER had starting problems, until now

once the car is going she is as sweet as a nut.

all this happened after she had come out of the garage,(about noon on 11th feb)...i dont want to point fingers etc, but it is human nature to think as to why, but i dont want to make any waves, (unless i have too), until i can get some help and/or advice, on fixing it myself...i am not mechanically minded though.

thanks guys

colin

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this