Sign in to follow this  
Phil Jones

Ka 6000Cd Rds Issue

Recommended Posts

Hi

Just tried to fit a 6000cd rds system in my daughter Ka. i thought i had the code and tried to insert the code 3 times. it came up with a count down of 30mins before i could try code again......the problem is i have waited over an hour and there now seems to be no power / display. I know there is power getting to the unit as the green lights come on when i turn the lights on but no display at all.

Would be really grateful for any help guys.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this