Sign in to follow this  
mcbutler

1.8 Tdci Odd Glow Plug Lamp Problem....

Recommended Posts

Well, after having this car one month and learning a lot I am currently left with only one (yes one) problem which is this;

After a fast run on the hi-way, 70mph plus for some distance (4 - 5 miles) I am then getting a glow plug lamp shortly after taking my foot from the throttle whilst the car is coasting in gear! It also goes into limp mode but some times dies altogether.

Any ideas anyone ??

Share this post


Link to post
Share on other sites

On most diesels the glow plug light also acts as a general ECU/Engine Management warning light. It's most likely a sensor or a clogged filter but you will need to get the fault code read to know what is wrong.

Share this post


Link to post
Share on other sites

had the same problem on my focus, turned out to be the throttle sensor on the pedal was worn, changed it and no problems since. apparently this is a common fault with the tddi so might be the same on yours

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this