Jump to content
Do Not Sell My Personal Information


Mk3 Powerfold Mirror Problems.


Ben87
 Share

Recommended Posts

I'm trying to fit some powerfold mirrors to my Mondeo, I've installed them the wiring is all there the puddle lights works but the mirrors don't fold there just folded in.

I've put the relay in what I thought was the right relay holder (brown holder under fuse box) didn't work!

Could I just not have the right relay?

Has anyone got any pictures of where the relay holder is?

Any help would be greatly appreciated

Sent from my iPhone using Ford OC

Link to comment
Share on other sites


... but the mirrors don't fold there just folded in.

You've confused me a bit here... So they're folded in and won't come back out? Have you fitted the proper mirror switch and are using it properly, i.e. pressing it down to fold them both in and out?

It's a brown relay and holder under the fusebox as you say as you say. Is the relay new? Always a chance the relay's a dud I suppose.

Link to comment
Share on other sites

Cheers Tezza I think that's what I'm gonna have to get.

Gforce - they came already folded ( sorry I should of explained that better) I'm starting to think I've just not used the right relay, it was one I took out of another Mondeo I was breaking.

Sent from my iPhone using Ford OC

Link to comment
Share on other sites

Ah right, get you now... and just to confirm you've fitted the proper folding switch on the inside of the door too? This one, that you push DOWN to operate the mirrors? http://www.ebay.co.uk/itm/FORD-MONDEO-MK3-POWERFOLD-ELECTRIC-WING-MIRROR-SWITCH-2004-2007-/221403909924?pt=UK_CarsParts_Vehicles_CarParts_SM&hash=item338cb38f24

Link to comment
Share on other sites

Yes mate, I got that switch with the mirrors and the wiring looms too but I didn't need the looms for the doors. I think I've just got carried away and hoped any relay would work.

I'm gonna get the proper relay try that and hope for the best :-)

Sent from my iPhone using Ford OC

Link to comment
Share on other sites

Is there 2 different types of relay for the powerfold wing mirrors?

The one on the pic on here looks like a brown relay but the ones on eBay look black and slightly smaller?

Sent from my iPhone using Ford OC

Link to comment
Share on other sites


Yeah I knew they had it written on I was going off the picture a seller had put on on eBay and it looked different that's why I was asking

Sent from my iPhone using Ford OC

Link to comment
Share on other sites

Did you get this sorted yet mate?

I wired mine up last night to fold with the double-lock press on the key fob, works a treat! Great sense of satisfaction when a wee mod like that comes off, all for the grand total of £1.99 for an extra relay! :D

Link to comment
Share on other sites

Yes mate got it sorted cheers. I refitted the mirrors on my dinner yesterday and popped the relay in and they worked a treat.

Im gonna do the same mod as you soon with getting them working with the key fob.

Sent from my iPhone using Ford OC

Link to comment
Share on other sites

That's good to hear mate, glad all is working well!

I just followed the wiki guide for the key fob function and it was really straightforward. I tried to leave as much in situ as possible, as I've a bad knack for breaking plastic retaining clips, so it was a bit fiddly trying to get access for scothclocking the wires from the new relay to the respective wires on the GEM and existing powerfold relay, but apart from that, dead easy.

I attached the 4 wires to the relay terminals on the bench in the shed first, just to minimise the faffing about in the footwell!

The only thing I did differently then from the guide was the earthing point...there's a bolt on the right hand side and I just fitted the ring terminal over this and screwed a little 10mm nut over it to secure it in place, rather than drill into the metal support bar that runs across behind the dash.

Sure just give us a shout if you've any probs or questions when you get round to it!

Link to comment
Share on other sites

Pretty sure that's the one for heated seats mate. Have you not got yours wired up? I think from your build thread that you have the half leather/alcantara heated/cooled seats from a Titanium so I assumed you had them fully working?

Link to comment
Share on other sites

Yeah their the seats mate but when I got the car the previous owner had completely butchered the wiring under the seats, cut the plugs off and had put terminals on each wire instead.....badly!

They worked but the airbag light was always on. Luckily I bought a mondeo of a mate and I kept the plugs from it to wire into mine just not got round to it yet.

If that's what that relay holder is for then that's a bonus :-).

Sent from my KFJWI using Ford OC mobile app

Link to comment
Share on other sites

Ah jeez, that sounds like a bad job! Why?! They should have been a direct fit...ah hang on, I'm just realising that there were full leathers fitted before, so this is when the butchering was done...

With a set of donor plugs it should be no problem, just wiring up the matching coloured wires like for like. What sort of heated seat switch have you got fitted at the minute then, just the pre-facelift on-off one? If so then there will unfortunately have been a bit of butchering to wiring behind this too probably unfortunately...

The seats you have at the minute should have been a direct plug and play, with the dash loom and floor looms all in place. I did this on my old ZS, fitted the same heated/cooled interior from an 07 TitX, then just fitted the relay and the variable heated/cooled switch (complete with the proper little mounting bracket ring!) and hey presto as all the required plugs and wiring looms were already in place.

Link to comment
Share on other sites

Yeah I'm assuming that the previous owner bought the seats with the plugs already cut off and thought he'd have a go himself without doing it properly.

Yep just the pre-facelift switch in when I got the car but I got the newer heated/cooling switch when I got the other Interior. Haha and your right there was butchering to the wiring for that too, there was only ever power to the switch when the lights were on!!!

Just need the relay and the mounting bracket for the switches really now, any chance you could shed some light on these please? ;-)

Sent from my KFJWI using Ford OC mobile app

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Forums


News


Membership