bprecey

Power Loss When Engine Warm 1.6Tdci

Recommended Posts

I have had many problems with my 55 plate Focus 1.6 TDCi Diesel but this one is a new one.

When the engine has warmed up and I've been driving for a while. The engine shows a complete lack of power and if I put my foot down or change gear the car will struggle to gain power like an asthmatic pensioner. If I rev it hard and almost to the limiter, it seems to clear the problem for a while.

When driving normally, this last two or three months, the car seems to lack power generally. The turbo doesn't seem to be providing the boost it once did.

Not sure if this is related. Prior to this loss of power, I was driving up a hill labouring the engine and suddenly there was an almighty bang and sudden complete loss of power. No limp mode but the symptoms of that followed this. I later learned that one of the turbo pipes had come off.

Are these problems related? Could this be an unwell turbo or dodgy injector?

Any pointers would be appreciated. Thanks in advance for any advice.

Share this post


Link to post
Share on other sites
 

Air leak in intercooler system will do the above, can you check your boost pressure?

Check all your hoses

Share this post


Link to post
Share on other sites

Thanks. I'll look into that. Do you think it's more likely to be that than the Turbo?

Share this post


Link to post
Share on other sites

Cant say, both would give similar symptoms, you need to check the boost pressure,

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now