Jump to content
Do Not Sell My Personal Information


The General Chat forum is ONLY for threads which DO NOT fit any other category. If your thread is anything do to with a specific model, it should go in the relevant model club section

Grr Motors !


chan1a
 Share

Recommended Posts


What happened exactly? 88k is very early for a clutch to go. Mine went on my Focus at 120k. They should easily be able to do about 150k if looked after properly. 88k seems way too early

Link to comment
Share on other sites

I was coming up to the round about and it just clicked then I had no clutch pedal its comes back up will go into gears if you use the revs just done that to get it home as just up the road so didn't need to tow it now time to check it over :/

Sent from my iPhone using Ford OC

Link to comment
Share on other sites

My mk5/6 Fiesta done something similar. Sounds like the clutch cable is slipping of the pedal. On the arm off the pedal there should be a pin/rod sticking out the side. The clutch cable has a loop that slides onto it.

Sometimes the clip that holds it in place falls off so it can slip off and you will loose clutch, the clutch will work again when it pops back on. I cable tied it back on to keep it in place and it was fine for 20,000 miles after until I sold it!

Let me know if that makes no sense.. Hard to explain!

Sent from my iPhone using Ford OC

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




×
×
  • Create New...

Forums


News


Membership