Jump to content
Do Not Sell My Personal Information


Dash lights after DIY service


DarrenR95
 Share

Recommended Posts

Hi everyone im new here.

So i recently serviced my Ford fiesta mk7 2009 petrol 1.25L.

I changed my air filter, spark plugs (from Bosch 4 prongs to Denso 1 prong, good idea?) and my oil.

Once i finished, i started up the engine bla bla bla, everything is okay except for some dash lights.

For the love of me I can not remember what dash lights used to show before actually cranking the engine.

One that concerns me most is the yellow steering wheel with an exclamation mark, which is on when i power up the car but once i start the engine it extinguishes.
The manual mentions a power steering fault, the steering is fine I have driven long distances since servicing it yesterday evening and no difficulties with it.

Likewise with the red oil symbol and yellow engine symbol which I think to be just check ups of which.

Could anyone tell me which lights are meant to be on the dash before cranking the engine and is this steering wheel light a common problem?

Thanks lads.

Darren.

Link to comment
Share on other sites


Welcome in :D

The dashlights are meant to light up then go out, if they don't go out there is a fault in that system - are all the lights out when the engine has started?

Link to comment
Share on other sites

Thanks for the past reply!

Well the operation is,

Second key click,

lights flash up and disappear, lights remaining are handbrake, red oil can and yellow engine and the yellow steering wheel with the exclamation mark until i crank the engine to which they all extinguish.

Its just i cant recall seeing the yellow steering wheel before which i thought was strange.

Well if it does go out after engine start by your words it must be okay then!

 

Thanks a lot M1tch!

Link to comment
Share on other sites

2 hours ago, DarrenR95 said:

Thanks for the past reply!

Well the operation is,

Second key click,

lights flash up and disappear, lights remaining are handbrake, red oil can and yellow engine and the yellow steering wheel with the exclamation mark until i crank the engine to which they all extinguish.

Its just i cant recall seeing the yellow steering wheel before which i thought was strange.

Well if it does go out after engine start by your words it must be okay then!

 

Thanks a lot M1tch!

No worries, the issue comes if any of then stay on, you can also do a test for all of the lights (and other things like gauge sweep and DTC codes), I can see you have a mk7 so check below for the details of how to get to the hidden menu:

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Forums


News


Membership