Jump to content
Do Not Sell My Personal Information


Mk7 fiesta zetec s boot light not working


Hulltiger
 Share

Recommended Posts


Hello and Welcome Tony:smile:

Have you checked you new bulb actually works, it is possible you've bought a new dud?

If it's the only lamp in the boot won't illuminate. Have you checked the door switch and the lamp socket?  Check the earth connections to the car?

If none of your interior lamps illuminate, check the fuse in the passenger footwell fuse box.

 

Link to comment
Share on other sites

Are you sure that you put it in properly, quite hard if you don't look? :laugh:

Is it a standard bulb or LED? (Some LED's have to be fitted in one specific way)

Link to comment
Share on other sites


I had the same problem in mine.

Does your interior map light work?

The interior lighting, footwell lights and boot light is all on the same circuit.

I replaced the map light unit for £20 and all of the lighting worked again!

If you can, use a multimeter to find the break in the circuit and go from there..

Sent from my iPad using Ford OC

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




×
×
  • Create New...

Forums


News


Membership