Sign in to follow this  
lufc08

1.4 TDCi misfire

Recommended Posts

Hey,

 

Just recently my 57 Fiesta has been randomly misfiring, it happens occasionally when idle and when driving as normal. The worst being totally undriveable as the car just started shaking uncontrollably and then cut out. I've taken it to my local garage but as always when he started it up the following morning it was fine. Apparently on his diagnostics it said something about a communication error to the injectors (an error he hasn't seen previous), he's stripped everything he could think of down and cleaned it out and gave it a road test, everything was still fine and when he ran the diagnostics again there were no errors.

 

Problem solved we thought. Last night it started again after 4 days of it being perfect.

 

Has anyone had this problem before and has a solution?

 

I trust the garage 100% to do the work but I just need to know what might need doing.

 

Thanks.

 

If i missed out any details you might need please let me know.

Share this post


Link to post
Share on other sites

Did you replace the small bit of wiring loom going to the injectors, might be something simple like a short in the wiring?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this