Sign in to follow this  
dannyb

Fiesta 1.4 tdci '06 lag/hesitation

Recommended Posts

Hi, after scouring the net I haven't been able to find a fault like mine. So wanted some advice if poss. I have owned my 06 Fiesta Tdci for over three years. It has always had a lag when pulling away. Also when stationary and out of gear, if you rev it, there is a noticeable delay in pick up. This can be a problem when pulling away at a junction, you need to get the revs op first before dropping the clutch. Once it gets to around 2k revs, it's fine. The issue hasn't worsened in over 3yrs, which tells me it's something and nothing. Any ideas?? 

I have just read an write up where a guy removed the airflow box and replaced it with a cone filter. He then unplugged the 'dosser valve'? He said this solved his lag/pick up. Feasible? 

Thanks 👍🏻😎

Share this post


Link to post
Share on other sites

Check the rubber pipe from the turbo to the waste-gate, it can split, if you take the air inlet pipe off can you see the turbo spinning?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this