Sign in to follow this  
Spark plug

Loud fan

Recommended Posts

I have a 2010 1.4TDCI MK7 fiesta, problem is fan kicks in within a minute even when engine is stone cold sometimes fan  runs at high speed which gets very loud. It does this even when air con is switched off. It does not stay on and goes off about 10 seconds after ignition is switched off 

Share this post


Link to post
Share on other sites

Sounds like the same problem I had with my 13 plate which was a failed bearing in the fan motor 

Share this post


Link to post
Share on other sites

a failed bearing in a fan will make it louder but I won't make it come on at times when it shouldn't be coming on

Share this post


Link to post
Share on other sites

I have changed the relay switch and the thermo cooling sensor - still keeps coming on !! 

Share this post


Link to post
Share on other sites
On 08/03/2017 at 7:54 PM, mama_bear said:

Sounds like the same problem I had with my 13 plate which was a failed bearing in the fan motor 

Did you ever get it sorted? 

Share this post


Link to post
Share on other sites

Same deal here on my '16 US spec 1.0. Fan runs at high speed even in below freezing weather, all the time, until you shut the car off. I checked with Forscan and it seems the fan is actually being commanded on the ECU, why I haven't an idea. I'm probably going to bring it up when it's time for servicing. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this